Amsterdam Solutions - UPDATE COMPLETED: Valorant Beast & Valorant Wall – Incident details

All systems operational

UPDATE COMPLETED: Valorant Beast & Valorant Wall

Resolved
Operational
Started about 1 year agoLasted less than a minute
Updates
  • Resolved
    Resolved

    Great news! We've made several improvements, including:

    • Fixed RCS

    • Fixed Team ESP buttons

    • Fixed crashing/lag issues

    This was an auto update, just run the same loader again for changes to take effect

    Enjoy the upgraded experience!